

<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
        <meta charset="utf-8" />
        <meta http-equiv="X-UA-Compatible" content="IE=edge" />
        <meta name="viewport" content="width=device-width, initial-scale=1" />
        <meta property="fb:pages" content="162290915432" />
        <meta name="google-site-verification" content="TkPbHnf5fGyE6vrIQcUc5hATUn1xbAXICAeDmJ7TtsM" />
        <meta name="msvalidate.01" content="925622343B9488A94BAEAC1029ED5D78" />

        
            
                

<title>Meghan Trainor Drops Two New Songs: Let You Be Right&quot; and &quot;Can’t Dance&quot; | Access Online</title>
<meta name="description" content="Meghan Trainor just released two new songs:  &quot;Let You Be Right&quot; and &quot;Can’t Dance.&quot;" />


<meta property="og:title" content="Meghan Trainor Drops Two New Songs: Let You Be Right&quot; and &quot;Can’t Dance&quot;">
<meta property="og:description" content="Meghan Trainor just released two new songs:  &quot;Let You Be Right&quot; and &quot;Can’t Dance.&quot;">
<meta property="og:site_name" content="Access Online">

    
    <meta property="og:image" content="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-901305970.2e16d0ba.fill-300x300.jpg">



<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@accessonline">
<meta name="twitter:creator" content="@accessonline">
<meta name="twitter:title" content="Meghan Trainor Drops Two New Songs: Let You Be Right&quot; and &quot;Can’t Dance&quot;">
<meta name="twitter:description" content="Meghan Trainor just released two new songs:  &quot;Let You Be Right&quot; and &quot;Can’t Dance.&quot;">


    
    <meta name="twitter:image:src" content="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-901305970.2e16d0ba.fill-300x300.jpg">


            
        

        <link rel="apple-touch-icon" sizes="57x57" href="/static/images/favicons/apple-touch-icon-57x57.png">
        <link rel="apple-touch-icon" sizes="60x60" href="/static/images/favicons/apple-touch-icon-60x60.png">
        <link rel="apple-touch-icon" sizes="72x72" href="/static/images/favicons/apple-touch-icon-72x72.png">
        <link rel="apple-touch-icon" sizes="76x76" href="/static/images/favicons/apple-touch-icon-76x76.png">
        <link rel="apple-touch-icon" sizes="114x114" href="/static/images/favicons/apple-touch-icon-114x114.png">
        <link rel="apple-touch-icon" sizes="120x120" href="/static/images/favicons/apple-touch-icon-120x120.png">
        <link rel="apple-touch-icon" sizes="144x144" href="/static/images/favicons/apple-touch-icon-144x144.png">
        <link rel="apple-touch-icon" sizes="152x152" href="/static/images/favicons/apple-touch-icon-152x152.png">
        <link rel="icon" type="image/png" href="/static/images/favicons/favicon-32x32.png" sizes="32x32">
        <link rel="icon" type="image/png" href="/static/images/favicons/android-chrome-192x192.png" sizes="192x192">
        <link rel="icon" type="image/png" href="/static/images/favicons/favicon-96x96.png" sizes="96x96">
        <link rel="icon" type="image/png" href="/static/images/favicons/favicon-16x16.png" sizes="16x16">
        <link rel="manifest" href="/static/images/favicons/manifest.json">
        <link rel="mask-icon" href="/static/images/favicons/safari-pinned-tab.svg" color="#5bbad5">
        <link rel="shortcut icon" href="/static/images/favicons/favicon.ico">
        <meta name="apple-mobile-web-app-title" content="Access Hollywood">
        <meta name="application-name" content="Access Hollywood">
        <meta name="msapplication-TileColor" content="#186fb6">
        <meta name="msapplication-TileImage" content="/static/images/favicons/mstile-144x144.png">
        <meta name="msapplication-config" content="/static/images/favicons/browserconfig.xml">
        <meta name="theme-color" content="#ffffff">

        
        <link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">
        

        <link rel="stylesheet" href="/static/CACHE/css/f72d7a12ec7c.css" type="text/css" />

        
        

        <script src="/static/js/vendor/modernizr.2.7.0.min.js"></script>

        <script>
            var AH = (function ($) {
              $.envId = 'prod';
              $.adQueue = [];
              return $;
            })(AH || {});

            // Ads
            
                
                    

                    var mpscall = {
                        "site": "accesshollywood-web",
                        'type': 'article detail',
                        'cat': 'news|music|articles',
                    };
                
            

            var mpsopts = {
                "host": "mps.nbcuni.com",
                "updatecorrelator": true
            };
            var mps = mps || {};
        </script>

        
        <!-- Facebook Pixel Code -->
        <script>
        !function(f,b,e,v,n,t,s)
        {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
        n.callMethod.apply(n,arguments):n.queue.push(arguments)};
        if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
        n.queue=[];t=b.createElement(e);t.async=!0;
        t.src=v;s=b.getElementsByTagName(e)[0];
        s.parentNode.insertBefore(t,s)}(window,document,'script',
        'https://connect.facebook.net/en_US/fbevents.js');
         fbq('init', '1404830592872456');
        fbq('track', 'PageView');
        </script>
        <noscript>
         <img height="1" width="1"
        src="https://www.facebook.com/tr?id=1404830592872456&ev=PageView
        &noscript=1"/>
        </noscript>
        <!-- End Facebook Pixel Code -->
    </head>

    <body class="container -article">
        
            <!-- Google Tag Manager -->
            <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-M68M25"
            height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
            <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','GTM-M68M25');</script>
            <!-- End Google Tag Manager -->
        

        
            
            

<a class="rail-advert-link" href="http://bit.ly/accessrue" target="_blank"></a>
<div class="rail-advert-link-mask"></div>



<style>
    body {
        background-image: url('https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/AH_RueLaLa_SPRING.original.jpg'); background-position: center top; background-repeat: no-repeat;
    }
</style>


        

        

        

<header class="pageheader">
    <div class="container">

        <aside class="banner">
            
<div class="mps-ad"> 

    <script type="text/javascript">
        (function() {
            var scriptTags = document.getElementsByTagName('script');
            var adContainer = scriptTags[scriptTags.length - 1].parentElement;

            document.addEventListener('DOMContentLoaded', function() {
                mps.insertAd(adContainer, 'topbanner');
            });
        })();
    </script>
</div>

        </aside>

        <div class="navigationbar">

            <nav class="navigation">
                
                <div class="mobilewrap">
                    <div class="mobileheaderadvert">
                        
<div class="mps-ad"> 

    <script type="text/javascript">
        (function() {
            var scriptTags = document.getElementsByTagName('script');
            var adContainer = scriptTags[scriptTags.length - 1].parentElement;

            document.addEventListener('DOMContentLoaded', function() {
                mps.insertAd(adContainer, 'mobiletopbox');
            });
        })();
    </script>
</div>

                    </div>
                    <div class="mobilelogowrapper">
                      <a class="logo"
                         href="/">
                          Access
                      </a>
                      <a class="dropdownbars"
                         id="js-toggle-menu"
                         href="#">
                          <i class="fa fa-bars"></i>
                      </a>
                    </div>
                </div>

                <ul id="js-links">
                    
                    

<li class="item -news"><a class="link js-dropdown"
               href="/news/">News</a><div class="headerdropdown -news"><div class="arrow"></div><ul class="childrenlinks"><li><a href="/news/"
                           class="link">
                            Latest
                        </a></li><li><a href="/news/tv/"
                                   class="link">
                                    TV
                                </a></li><li><a href="/news/movies/"
                                   class="link">
                                    Movies
                                </a></li><li><a href="/news/music/"
                                   class="link">
                                    Music
                                </a></li><li><a href="/news/personalities/"
                                   class="link">
                                    Personalities
                                </a></li></ul><ul class="articles"><li class="preview"><a href="/articles/world-dance-renewed-season-3/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/NUP_181390_1066.2e16d0ba.fill-140x82.jpg"
                         alt="Jenna Dewan, Ne-Yo, Jennifer Lopez and Derek Hough in a cast shot for NBC&#39;s &#39;World of Dance&#39;"></a><a href="/articles/world-dance-renewed-season-3/"
               class="link">
                &#39;World Of Dance&#39; Renewed For S3
            </a></li><li class="preview"><a href="/articles/brooklyn-nine-nine-canceled-see-how-celebs-reacted/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/B99-521_SC1_JPF0054_f_hires2.2e16d0ba.fill-140x82.jpg"
                         alt="Andy Samberg in a scene from &#39;Brooklyn Nine-Nine&#39;"></a><a href="/articles/brooklyn-nine-nine-canceled-see-how-celebs-reacted/"
               class="link">
                &#39;Brooklyn Nine-Nine&#39; Canceled
            </a></li><li class="preview"><a href="/articles/taylor-swifts-reputation-stadium-tour-must-see-celebration-world-class-artistry-review/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-729510581179861.2e16d0ba.fill-140x82.jpg"
                         alt="Inside Taylor Swift&#39;s &#39;Reputation&#39; Tour Opening Night"></a><a href="/articles/taylor-swifts-reputation-stadium-tour-must-see-celebration-world-class-artistry-review/"
               class="link">
                Taylor&#39;s &#39;Reputation&#39; Tour (Review)
            </a></li><li class="preview"><a href="/articles/carrie-underwood-says-every-day-shes-getting-back-normal-after-fall/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-946721600.2e16d0ba.fill-140x82.jpg"
                         alt="Carrie Underwood, ACM Awards 2018"></a><a href="/articles/carrie-underwood-says-every-day-shes-getting-back-normal-after-fall/"
               class="link">
                Carrie Talks About Fall &amp; Recovery
            </a></li></ul></div></li><li class="item -photos"><a class="link "
               href="/photos/">Photos</a><div class="headerdropdown -photos"><div class="arrow"></div><ul class="childrenlinks"><li><a href="/photos/"
                           class="link">
                            Latest
                        </a></li></ul><ul class="articles"><li class="preview"><a href="/galleries/most-elaborate-met-gala-2018-crowns-headpieces/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-955766580.2e16d0ba.fill-140x82.jpg"
                         alt="Madonna attends the Heavenly Bodies: Fashion &amp; The Catholic Imagination Costume Institute Gala at The Metropolitan Museum of Art on May 7, 2018 in New York City. (Photo by Neilson Barnard/Getty Images)"></a><a href="/galleries/most-elaborate-met-gala-2018-crowns-headpieces/"
               class="link">
                Met Gala 2018 Crowns!
            </a></li><li class="preview"><a href="/galleries/2018-met-gala-hot-couple-shots/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-955759020.2e16d0ba.fill-140x82.jpg"
                         alt="Tom Brady and Gisele Bundchen attends the Heavenly Bodies: Fashion &amp; The Catholic Imagination Costume Institute Gala at The Metropolitan Museum of Art on May 7, 2018 in New York City"></a><a href="/galleries/2018-met-gala-hot-couple-shots/"
               class="link">
                2018 Met Gala: Hot Couple Shots
            </a></li><li class="preview"><a href="/galleries/stars-shine-2018-met-gala/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-955761780.2e16d0ba.fill-140x82.jpg"
                         alt="Priyanka Chopra attends the Heavenly Bodies: Fashion &amp; The Catholic Imagination Costume Institute Gala at The Metropolitan Museum of Art on May 7, 2018 in New York City"></a><a href="/galleries/stars-shine-2018-met-gala/"
               class="link">
                2018 Met Gala: Red Carpet Stunners! 
            </a></li><li class="preview"><a href="/galleries/stars-hit-2018-kentucky-derby/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-955035926.2e16d0ba.fill-140x82.jpg"
                         alt="Dannielynn Birkhead and Larry Birkhead attend Kentucky Derby 144 on May 5, 2018 in Louisville, Kentucky. (Photo by Dia Dipasupil/Getty Images for Chruchill Downs)"></a><a href="/galleries/stars-hit-2018-kentucky-derby/"
               class="link">
                Stars Hit The 2018 Kentucky Derby 
            </a></li></ul></div></li><li class="item -videos"><a class="link "
               href="/videos/">Videos</a><div class="headerdropdown -videos"><div class="arrow"></div><ul class="childrenlinks"><li><a href="/videos/"
                           class="link">
                            Latest
                        </a></li></ul><ul class="articles"><li class="preview"><a href="/videos/irina-shayk-amber-heard-stun-in-barely-there-ensembles-at-the-2018-cannes-film-festival/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-3300609978286204.2e16d0ba.fill-140x82.jpg"
                         alt="Irina Shayk &amp; Amber Heard Stun In Barely-There Ensembles At The 2018 Cannes Film Festival"></a><a href="/videos/irina-shayk-amber-heard-stun-in-barely-there-ensembles-at-the-2018-cannes-film-festival/"
               class="link">
                Irina Shayk &amp; Amber Heard Stun In ...
            </a></li><li class="preview"><a href="/videos/man-arrested-on-suspicion-of-breaking-into-rihannas-home/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-2694687727456950.2e16d0ba.fill-140x82.jpg"
                         alt="Man Arrested On Suspicion Of Breaking Into Rihanna&#39;s Home"></a><a href="/videos/man-arrested-on-suspicion-of-breaking-into-rihannas-home/"
               class="link">
                Man Arrested On Suspicion Of Break...
            </a></li><li class="preview"><a href="/videos/agt-judges-on-season-13s-scarier-acts-not-saying-no-when-contestants-ask-for-a-volunteer/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-6906625221748468.2e16d0ba.fill-140x82.jpg"
                         alt="&#39;AGT&#39; Judges On Season 13&#39;s Scarier Acts &amp; Not Saying No When Contestants Ask For A Volunteer!"></a><a href="/videos/agt-judges-on-season-13s-scarier-acts-not-saying-no-when-contestants-ask-for-a-volunteer/"
               class="link">
                &#39;AGT&#39; Judges On Season 13&#39;s Scarie...
            </a></li><li class="preview"><a href="/videos/kendall-jenner-admits-its-weird-kylie-jenner-had-a-baby-before-her/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-5629848964808760.2e16d0ba.fill-140x82.jpg"
                         alt="Kendall Jenner Admits It&#39;s &#39;Weird&#39; Kylie Jenner Had A Baby Before Her"></a><a href="/videos/kendall-jenner-admits-its-weird-kylie-jenner-had-a-baby-before-her/"
               class="link">
                Kendall Jenner Admits It&#39;s &#39;Weird&#39;...
            </a></li></ul></div></li><li class="item -lifestyle"><a class="link js-dropdown"
               href="/lifestyle/">Lifestyle</a><div class="headerdropdown -lifestyle"><div class="arrow"></div><ul class="childrenlinks"><li><a href="/lifestyle/"
                           class="link">
                            Latest
                        </a></li><li><a href="/lifestyle/recipes/"
                                   class="link">
                                    Recipes
                                </a></li><li><a href="/lifestyle/parenting/"
                                   class="link">
                                    Parenting
                                </a></li><li><a href="/lifestyle/style/"
                                   class="link">
                                    Style
                                </a></li></ul><ul class="articles"><li class="preview"><a href="/videos/rue-la-la-all-access-style-151/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-782455225364423.2e16d0ba.fill-140x82.jpg"
                         alt="Rue La La All-Access Style"></a><a href="/videos/rue-la-la-all-access-style-151/"
               class="link">
                Rue La La All-Access Style
            </a></li><li class="preview"><a href="/videos/rue-la-la-all-access-style-150/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-74535272656826.2e16d0ba.fill-140x82.jpg"
                         alt="Rue La La All-Access Style"></a><a href="/videos/rue-la-la-all-access-style-150/"
               class="link">
                Rue La La All-Access Style
            </a></li><li class="preview"><a href="/videos/kristen-stewart-wows-in-pastel-blue-suit-at-cannes-photo-call/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-7867442499400191.2e16d0ba.fill-140x82.jpg"
                         alt="Kristen Stewart Wows In Pastel Blue Suit At Cannes Photo Call "></a><a href="/videos/kristen-stewart-wows-in-pastel-blue-suit-at-cannes-photo-call/"
               class="link">
                Kristen Stewart Wows In Pastel Blu...
            </a></li><li class="preview"><a href="/videos/stars-sizzle-at-2018-met-gala-after-parties/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-1109011814823402.2e16d0ba.fill-140x82.jpg"
                         alt="Stars Sizzle At 2018 Met Gala After Parties "></a><a href="/videos/stars-sizzle-at-2018-met-gala-after-parties/"
               class="link">
                Stars Sizzle At 2018 Met Gala Afte...
            </a></li></ul></div></li><li class="item -live"><a class="link js-dropdown"
               href="/live/">Access Live</a><div class="headerdropdown -live"><div class="arrow"></div><ul class="childrenlinks"><li><a href="/live/"
                           class="link">
                            Latest
                        </a></li><li><a href="/live/features/"
                               class="link">
                                Features
                            </a></li><li><a href="/live/photos/"
                               class="link">
                                Photos
                            </a></li><li><a href="/live/videos/"
                               class="link">
                                Videos
                            </a></li></ul><ul class="articles"><li class="preview"><a href="/videos/rue-la-la-all-access-style-150/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-74535272656826.2e16d0ba.fill-140x82.jpg"
                         alt="Rue La La All-Access Style"></a><a href="/videos/rue-la-la-all-access-style-150/"
               class="link">
                Rue La La All-Access Style
            </a></li><li class="preview"><a href="/videos/vin-diesel-says-mia-toretto-is-coming-back-africa-may-be-location-for-next-fast-furious/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-1307559362012776.2e16d0ba.fill-140x82.jpg"
                         alt="Vin Diesel Says Mia Toretto Is Coming Back &amp; Africa May Be Location For Next &#39;Fast &amp; Furious&#39;  "></a><a href="/videos/vin-diesel-says-mia-toretto-is-coming-back-africa-may-be-location-for-next-fast-furious/"
               class="link">
                Vin Diesel Says Mia Toretto Is Com...
            </a></li><li class="preview"><a href="/videos/priyanka-chopra-shares-what-she-thinks-will-go-down-at-prince-harry-meghan-markles-wedding/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-7118340668458538.2e16d0ba.fill-140x82.jpg"
                         alt="Priyanka Chopra Shares What She Thinks Will Go Down At Prince Harry &amp; Meghan Markle&#39;s Wedding"></a><a href="/videos/priyanka-chopra-shares-what-she-thinks-will-go-down-at-prince-harry-meghan-markles-wedding/"
               class="link">
                Priyanka Chopra Shares What She Th...
            </a></li><li class="preview"><a href="/videos/rue-la-la-all-access-style-149/"
               class="image"><img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-3630979445914668.2e16d0ba.fill-140x82.jpg"
                         alt="Rue La La All-Access Style"></a><a href="/videos/rue-la-la-all-access-style-149/"
               class="link">
                Rue La La All-Access Style
            </a></li></ul></div></li>



                    <li class="item -tips">
                        <a class="link"
                           href="/contact/">
                            Got a news tip?
                        </a>
                    </li>

                </ul>
            </nav>

            <form action="/search/" method="get">
                <div class="search" id="js-search">
                    <i class="fa fa-search icon" onclick="$(this).closest('form').submit();"></i>

                    <input id="pageheaderSearch"
                           class="input"
                           name="query"
                           placeholder="search"
                           type="text">
                </div>
            </form>

            <div class="social">
                <ul>
    <li>
        <a href="https://www.youtube.com/accessonline"
           class="link"
           target="_blank"
           title="Youtube">
            YouTube
        </a>
    </li>
    <li>
        <a href="http://www.twitter.com/accessonline"
           class="link"
           target="_blank"
           title="Twitter">
            Twitter
        </a>
    </li>
    <li>
        <a href="http://www.facebook.com/accessonline"
           class="link"
           target="_blank"
           title="Facebook">
            Facebook
        </a>
    </li>
    <li>
        <a href="http://instagram.com/accessonline"
           class="link"
           target="_blank"
           title="Instagram">
            Instagram
        </a>
    </li>
    <li class="snapchat">
        <a href="https://www.snapchat.com/add/officialaccess"
           class="link"
           target="_blank"
           title="Snapchat">
            Snapchat
        </a>
    </li>
</ul>

            </div>

        </div>

    </div>
</header>


        
    <article class="article"
             itemscope=""
             itemtype="http://schema.org/Article">

        <meta itemprop="image"
              content="">
        <meta itemprop="description"
              content="">
        <meta itemprop="alternativeHeadline"
              content="">

        

        <h1 class="heading"
            itemprop="headline">
            Meghan Trainor Drops Two New Songs: Let You Be Right&quot; and &quot;Can’t Dance&quot;
        </h1>

        <aside class="meta">
            
                <time class="publisheddate"
                    itemprop="datePublished"
                    datetime="2018-05-10 06:24">
                    May 10, 2018 6:24 AM PDT
                </time>
            

            
<div class="post-share-bar">
    <script src="//s.po.st/static/v3/post-widget.js#publisherKey=fqcio0edt2amovv1e4rn"></script>

    <div class="share-widget-1"></div>

    <a class="post-powered-by" href="http://po.st/" target="_post">
        <div class="post-powered-by-image"></div>
    </a>

    <br>

    <script type="text/javascript">
    (function(only_for) {
        var isDesktop = Modernizr.mq('only screen and (min-width: 992px)');
        var isTablet = Modernizr.mq('screen and (min-width:720px) and (max-width:992px)');
        var isMobile = Modernizr.mq('screen and (min-width:320px) and (max-width:720px)');

        if (!eval(only_for)) {
            return;
        }

        post_widget(".share-widget-1", {
            afterShare: false,
            sharePopups: true,
            transformations: {
                tracking: true,
                shorten: false
            },
            gaTrackSocialInteractions: true,
            size: 'medium',
            vertical: false,

            title: 'Meghan Trainor Drops Two New Songs: Let You Be Right\u0022 and \u0022Can’t Dance\u0022',
            url: 'http://ahwd.tv/YRjpZs' == 'None' ? document.location.href : 'http://ahwd.tv/YRjpZs',
            
                
                image: "https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-901305970.2e16d0ba.fill-300x300.jpg",
            
            buttons: ['facebook', 'googleplus', 'twitter', 'pinterest' ],
            services: {
                p_share_popup: 'aollifestream, wordpress, blogger, pinterest, stumbleupon, more',
                more_popup: 'email, print, delicious, digg',
                twitter: {
                    via: 'accessonline'
                },
                mobileOverlay: true
            }
        });

    })('isDesktop');
    </script>
</div>

        </aside>

        <div class="body"
             itemprop="articleBody">
            
                
                    <section class="block-text">
                        <div class="rich-text"><p>Meghan Trainor just released two new songs:  "Let You Be Right" and "Can’t Dance."</p><p>The two new songs come off her upcoming third album, which is set to drop later this year. The up-temp and sassy songs are definitely going to get you toe-tapping. The songs come after Meghan's hit single, "No Excuses," which has been climbing the charts. </p><p>Check out Meghan's two new songs below! </p></div>
                    </section>
                
            
                
                    <section class="block-embed">
                        <iframe width="480" height="270" src="https://www.youtube.com/embed/nNZrc_XvF30?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
                    </section>
                
            
                
                    <section class="block-embed">
                        <iframe width="480" height="270" src="https://www.youtube.com/embed/0xFgVgPpkVg?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>
                    </section>
                
            
        </div>

        
            

<div id="source"
     class="articlesource"
     xmlns:dc="http://purl.org/dc/elements/1.1/">

    <dl property="dc:rights" class="statement">
        <dt title="Copyright">Copyright &copy;</dt>
        <dd>
            <span property="dc:dateCopyrighted">2018</span> by
            <span property="dc:publisher">
                <div class="rich-text"><p><a href="http://www.nbc.com">NBCUniversal, Inc</a>.</p></div>
                All Rights Reserved.
            </span>
        </dd>
    </dl>

    <span>
        This material may not be republished, broadcast, rewritten
        or redistributed.
    </span>
</div>

        

        <div class="tablet-and-mobile-adverts">
            
<div class="mps-ad"> 

    <script type="text/javascript">
        (function() {
            var scriptTags = document.getElementsByTagName('script');
            var adContainer = scriptTags[scriptTags.length - 1].parentElement;

            document.addEventListener('DOMContentLoaded', function() {
                mps.insertAd(adContainer, 'tablettopbox');
            });
        })();
    </script>
</div>


            

            
    

<div class="partneradvert">
    <a href="http://bit.ly/accessruehp">
        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/accesshollywood_sitead_may9.2e16d0ba.fill-300x350.jpg" width="300" height="350" alt="RueLaLa">
    </a>
</div>




        </div>

        
            <div class="morenews">
                <h3 class="heading">
                    Related news
                </h3>

                <ul class="articles">
                    
                        <li class="item">
                            <a href="/articles/meghan-trainor-goes-fangirl-over-meeting-beyonce-155900/"
                               class="link">

                                
                                
                                    <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/225024.2e16d0ba.fill-295x279.jpg" width="295" height="279" alt="Meghan Trainor talks with Access Hollywood on January 9, 2015" class="image">
                                

                                <span class="text">
                                    Meghan Trainor&#39;s Beyonce Fangirl Moment
                                </span>
                            </a>
                        </li>
                    
                        <li class="item">
                            <a href="/articles/meghan-trainor-postpones-2-shows-due-to-hemorrhage-on-vocal-cords-162778/"
                               class="link">

                                
                                
                                    <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/231967.2e16d0ba.fill-295x279.jpg" width="295" height="279" alt="Meghan Trainor attends the 2015 iHeartRadio Music Awards at The Shrine Auditorium on March 29, 2015 in Los Angeles" class="image">
                                

                                <span class="text">
                                    Meghan Trainor Delays Shows 
                                </span>
                            </a>
                        </li>
                    
                </ul>
            </div>
        

    </article>

    <div class="tablet-wide-latest-news">
        

<section class="latestnews">
    <h2 class="heading">
        Latest News
    </h2>

    <ul>
        
            <li class="newsitem">
                <a href="/articles/world-dance-renewed-season-3/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/NUP_181390_1066.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Jenna Dewan, Ne-Yo, Jennifer Lopez and Derek Hough in a cast shot for NBC&#39;s &#39;World of Dance&#39;">
                     
                </a>
                <a href="/articles/world-dance-renewed-season-3/"
                   class="link">
                    &#39;World Of Dance&#39; Renewed For S3
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/brooklyn-nine-nine-canceled-see-how-celebs-reacted/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/B99-521_SC1_JPF0054_f_hires2.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Andy Samberg in a scene from &#39;Brooklyn Nine-Nine&#39;">
                     
                </a>
                <a href="/articles/brooklyn-nine-nine-canceled-see-how-celebs-reacted/"
                   class="link">
                    &#39;Brooklyn Nine-Nine&#39; Canceled
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/selena-gomez-seemingly-sings-about-ex-justin-bieber-new-track-back-you/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-2852743767136407.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Is Justin Bieber&#39;s Wolf Ring A Tribute To Selena Gomez?">
                     
                </a>
                <a href="/articles/selena-gomez-seemingly-sings-about-ex-justin-bieber-new-track-back-you/"
                   class="link">
                    Is Selena Singing About Justin?
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/taylor-swifts-reputation-stadium-tour-must-see-celebration-world-class-artistry-review/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-729510581179861.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Inside Taylor Swift&#39;s &#39;Reputation&#39; Tour Opening Night">
                     
                </a>
                <a href="/articles/taylor-swifts-reputation-stadium-tour-must-see-celebration-world-class-artistry-review/"
                   class="link">
                    Taylor&#39;s &#39;Reputation&#39; Tour (Review)
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/carrie-underwood-says-every-day-shes-getting-back-normal-after-fall/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-946721600.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Carrie Underwood, ACM Awards 2018">
                     
                </a>
                <a href="/articles/carrie-underwood-says-every-day-shes-getting-back-normal-after-fall/"
                   class="link">
                    Carrie Talks About Fall &amp; Recovery
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/anna-wintour-scarlett-johansson-defend-georgina-chapmans-marchesa-collection/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-955769802.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt=" Colin Jost and Scarlett Johansson attend the Heavenly Bodies: Fashion &amp; The Catholic Imagination Costume Institute Gala at The Metropolitan Museum of Art on May 7, 2018 in New York City. (Photo by Jamie McCarthy/Getty Images)">
                     
                </a>
                <a href="/articles/anna-wintour-scarlett-johansson-defend-georgina-chapmans-marchesa-collection/"
                   class="link">
                    ScarJo Speaks Out For Marchesa
                </a>
            </li>
        
    </ul>
</section>


    </div>

    <div class="article-sidebar">
        

<aside class="sidebar">
    
<div class="mps-ad"> 

    <script type="text/javascript">
        (function() {
            var scriptTags = document.getElementsByTagName('script');
            var adContainer = scriptTags[scriptTags.length - 1].parentElement;

            document.addEventListener('DOMContentLoaded', function() {
                mps.insertAd(adContainer, 'topbox');
            });
        })();
    </script>
</div>


    

<section class="latestnews">
    <h2 class="heading">
        Latest News
    </h2>

    <ul>
        
            <li class="newsitem">
                <a href="/articles/world-dance-renewed-season-3/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/NUP_181390_1066.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Jenna Dewan, Ne-Yo, Jennifer Lopez and Derek Hough in a cast shot for NBC&#39;s &#39;World of Dance&#39;">
                     
                </a>
                <a href="/articles/world-dance-renewed-season-3/"
                   class="link">
                    &#39;World Of Dance&#39; Renewed For S3
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/brooklyn-nine-nine-canceled-see-how-celebs-reacted/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/B99-521_SC1_JPF0054_f_hires2.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Andy Samberg in a scene from &#39;Brooklyn Nine-Nine&#39;">
                     
                </a>
                <a href="/articles/brooklyn-nine-nine-canceled-see-how-celebs-reacted/"
                   class="link">
                    &#39;Brooklyn Nine-Nine&#39; Canceled
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/selena-gomez-seemingly-sings-about-ex-justin-bieber-new-track-back-you/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-2852743767136407.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Is Justin Bieber&#39;s Wolf Ring A Tribute To Selena Gomez?">
                     
                </a>
                <a href="/articles/selena-gomez-seemingly-sings-about-ex-justin-bieber-new-track-back-you/"
                   class="link">
                    Is Selena Singing About Justin?
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/taylor-swifts-reputation-stadium-tour-must-see-celebration-world-class-artistry-review/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/bc-729510581179861.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Inside Taylor Swift&#39;s &#39;Reputation&#39; Tour Opening Night">
                     
                </a>
                <a href="/articles/taylor-swifts-reputation-stadium-tour-must-see-celebration-world-class-artistry-review/"
                   class="link">
                    Taylor&#39;s &#39;Reputation&#39; Tour (Review)
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/carrie-underwood-says-every-day-shes-getting-back-normal-after-fall/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-946721600.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt="Carrie Underwood, ACM Awards 2018">
                     
                </a>
                <a href="/articles/carrie-underwood-says-every-day-shes-getting-back-normal-after-fall/"
                   class="link">
                    Carrie Talks About Fall &amp; Recovery
                </a>
            </li>
        
            <li class="newsitem">
                <a href="/articles/anna-wintour-scarlett-johansson-defend-georgina-chapmans-marchesa-collection/"
                   class="link">

                    
                        
                        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/GettyImages-955769802.2e16d0ba.fill-140x140.jpg"
                             class="image"
                             alt=" Colin Jost and Scarlett Johansson attend the Heavenly Bodies: Fashion &amp; The Catholic Imagination Costume Institute Gala at The Metropolitan Museum of Art on May 7, 2018 in New York City. (Photo by Jamie McCarthy/Getty Images)">
                     
                </a>
                <a href="/articles/anna-wintour-scarlett-johansson-defend-georgina-chapmans-marchesa-collection/"
                   class="link">
                    ScarJo Speaks Out For Marchesa
                </a>
            </li>
        
    </ul>
</section>



    
    

    
    

<div class="partneradvert">
    <a href="http://bit.ly/accessruehp">
        <img src="https://d919ce141ef35c47fc40-b9166a60eccf0f83d2d9c63fa65b9129.ssl.cf5.rackcdn.com/images/accesshollywood_sitead_may9.2e16d0ba.fill-300x350.jpg" width="300" height="350" alt="RueLaLa">
    </a>
</div>




</aside>

    </div>



        
<footer class="pagefooter">

    <nav class="sitemap -primary">
        <ul>
            <li><a class="link" href="/about/">About</a></li>
            <li><a class="link" href="/contact/">Contact</a></li>
            <li><a class="link" href="/closedcaption/">Closed Caption</a></li>
            <li><a class="link" target="_blank" href="http://www.nbcuni.com/privacy/">Privacy Policy</a></li>
            <li><a class="link" target="_blank" href="http://www.nbcuni.com/terms/">Terms &amp; Conditions</a></li>
            <li><a class="link" href="/stations/">Find My Station</a></li>
        </ul>
    </nav>

    <nav class="sitemap">
        <ul>
            <li><a class="link" target="_blank" href="http://www.comcast.com/independentprogramming">Independent Programming Info</a></li>
            <li><a id="_bapw-link" class="link -adchoices" href="#"><span id="_bapw-icon">AdChoices</span></a></li>
        </ul>
    </nav>

    <nav class="sociallinks">
        <ul>
    <li>
        <a href="https://www.youtube.com/accessonline"
           class="link"
           target="_blank"
           title="Youtube">
            YouTube
        </a>
    </li>
    <li>
        <a href="http://www.twitter.com/accessonline"
           class="link"
           target="_blank"
           title="Twitter">
            Twitter
        </a>
    </li>
    <li>
        <a href="http://www.facebook.com/accessonline"
           class="link"
           target="_blank"
           title="Facebook">
            Facebook
        </a>
    </li>
    <li>
        <a href="http://instagram.com/accessonline"
           class="link"
           target="_blank"
           title="Instagram">
            Instagram
        </a>
    </li>
    <li class="snapchat">
        <a href="https://www.snapchat.com/add/officialaccess"
           class="link"
           target="_blank"
           title="Snapchat">
            Snapchat
        </a>
    </li>
</ul>

    </nav>

    <nav class="relatedsites">

        <h6 class="heading">Visit our related sites</h6>

        <ul>
            <li><a class="link" target="_blank" href="http://www.nbc.com/">NBC</a></li>
            <li><a class="link" target="_blank" href="http://www.fandango.com/">Fandango</a></li>
            <li><a class="link" target="_blank" href="http://www.today.com/">TODAY</a></li>
            <li><a class="link" target="_blank" href="http://www.bravotv.com/">Bravo</a></li>
            <li><a class="link" target="_blank" href="http://xfinity.comcast.net/">Xfinity</a></li>
        </ul>
    </nav>


    <div id="copyright" class="copyright" xmlns:dc="http://purl.org/dc/elements/1.1/">

        <dl property="dc:rights" class="statement">
            <dt title="Copyright">Copyright &copy;</dt>
            <dd>
                <span property="dc:dateCopyrighted">2018</span> by
                <span property="dc:publisher">
                    NBCUniversal, Inc. All Rights Reserved.
                    Part of NBCU Digital Entertainment.
                </span>
            </dd>
        </dl>

        <span>
            This material may not be republished, broadcast, rewritten
            or redistributed.
        </span>
    </div>

</footer>


        <script type="text/javascript" src="/static/CACHE/js/14c5aa9260eb.js"></script>

        

        <script>
            (function(){var e=document,b,a=(e.location.protocol=="https:"?"https":"http"),c=(a=="https"?"https://info.evidon.com/c/betrad/pub/":"http://cdn.betrad.com/pub/");e.getElementById("_bapw-icon").src=c+"icon1.png";e.getElementById("_bapw-link").onclick=function(){var f=this;function d(i,l){var j=e.getElementsByTagName("head")[0]||e.documentElement,h=false,g=e.createElement("script");function k(){g.onload=g.onreadystatechange=null;j.removeChild(g);l()}g.src=i;g.onreadystatechange=function(){if(!h&&(this.readyState=="loaded"||this.readyState=="complete")){h=true;k()}};g.onload=k;j.insertBefore(g,j.firstChild)}this.onclick="return false";d(a+"://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js",function(){d(c+"pub1.js",function(){BAPW.i(f,{pid:209,ocid:908},false)})});return false};b=new Image();b.src=a+"://l.betrad.com/pub/p.gif?pid=209&ocid=908&ii=1&r="+Math.random()}());
        </script>

        
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.2";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<script>
  $(function() {
    // Fix ads for iPad rotation
    var getScreen = function() {
      var w = $( window ).width();
      return {
        'desktop': w >= 990,
        'tablet': w < 990 && w > 720 };
    };
    var sidebarAd = {
      'tablet': $( '.tablet-and-mobile-adverts .mps-ad' ).first(),
      'desktop': $( '.article-sidebar .sidebar .mps-ad' ).first()
    }
    var initScreen = getScreen();
    $( window ).resize(function() {
      var nowScreen = getScreen();
      if (initScreen.tablet && nowScreen.desktop) {
        $('.tablet-and-mobile-adverts').show();
        $('.tablet-and-mobile-adverts .partneradvert').hide();
        el = $( sidebarAd.tablet ).find( '.mps-slot' ).first();
        el2 = $(sidebarAd.desktop);
        el.css('position', 'absolute');
        el.offset(el2.offset());
        el2.height(el.height());
        el2.width(el.width());
      } else if (initScreen.desktop && nowScreen.tablet) {
        $('.article-sidebar').show();
        $('.article-sidebar .latestnews').hide();
        $('.article-sidebar .partneradvert').hide();
        el = $( sidebarAd.desktop ).find( '.mps-slot' ).first();
        el2 = $(sidebarAd.tablet);
        el.css('position', 'absolute');
        el.offset(el2.offset());
        el2.height(el.height());
        el2.width(el.width());
      } else {
        $('.article-sidebar .sidebar').attr('style', '');
        $('.article-sidebar .latestnews').attr('style', '');
        $('.article-sidebar .partneradvert').attr('style', '');
        $( sidebarAd.desktop ).find( '.mps-slot' ).first().attr('style', '');
        $(sidebarAd.tablet).attr('style', '');
        $('.tablet-and-mobile-adverts').attr('style', '');
        $('.tablet-and-mobile-adverts .partneradvert').attr('style', '');
        $( sidebarAd.tablet ).find( '.mps-slot' ).first().attr('style', '');
        $(sidebarAd.desktop).attr('style', '');
      }
    });
  });
</script>


        
        <script id="mps-ext-load" src="//mps.nbcuni.com/fetch/ext/load-accesshollywood-web.js"></script>
        <script>
            mps.writeFooter();
        </script>

        
        <script>
          var _comscore = _comscore || [];
          _comscore.push({ c1: "2", c2: "6035083" });
          (function() {
            var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
            s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
            el.parentNode.insertBefore(s, el);
          })();
        </script>
        <noscript>
          <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
        </noscript>

        
        
        <!-- Pollware for AccessHollywood -->
        <script>
        !function(D,id,s){
        if(D.getElementById(id))return;
        s=D.createElement('script');s.id=id;
        s.src='//pollware-cdn.sodahead.com/pollware/pollware_978.js';
        D.getElementsByTagName('head')[0].appendChild(s);
        }(document,'sh-pollware-loader');
        </script>
        

    </body>
</html>
